Clever sign on
Incident Report for Brunswick County Schools
Resolved
This incident has been resolved.
Posted Sep 13, 2023 - 12:29 EDT
Monitoring
From our vendor:
The Clever Portal is now working and all users should be able to login to Clever. We apologize for the inconvenience and our teams will continue to monitor the situation. If you are still experiencing login issues, please reach out to Clever Support at support.clever.com

Updates can be found on their status page: https://status.clever.com
Posted Sep 13, 2023 - 11:14 EDT
Update
From our vendor: Update - We are continuing to investigate this issue.
Sep 13, 2023 - 10:06 EST
Updates can be found on their status page: https://status.clever.com
Posted Sep 13, 2023 - 10:08 EDT
Investigating
From our vendor: The Clever Portal is experiencing downtime for all users. Our teams are currently investigating the issue and will provide status updates. We sincerely apologize for the inconvenience.
Updates can be found on their status page: https://status.clever.com
Posted Sep 13, 2023 - 09:18 EDT
This incident affected: Clever Products (Clever).