Printing Services Down
Incident Report for Brunswick County Schools
Resolved
Issues have been identified, tested and is resolved.
Posted Oct 05, 2021 - 11:55 EDT
Investigating
We are working to resolve printing issues.
Posted Oct 05, 2021 - 08:51 EDT