Clever login
Incident Report for Brunswick County Schools
Resolved
status.clever.com
This incident has been resolved.
Posted Nov 13, 2023 - 11:43 EST
Monitoring
https://status.clever.com
Incident status: Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2023 - 11:09 EST
Update
We are continuing to investigate this issue.
Posted Nov 13, 2023 - 09:27 EST
Investigating
From our vendor https://status.clever.com :

“The Clever Portal is currently down for some users. Our teams are still investigating the issue and we will provide status updates as soon as they are available. We sincerely apologize for the inconvenience.”
Posted Nov 13, 2023 - 09:24 EST
This incident affected: Clever Products (Clever).